PSA Interface Checker - Verifier son interface

Avatar du membre
Feel
Messages : 3
Enregistré le : mer. juil. 19, 2023 8:28 pm
Réputation : 0
Localisation : Non renseigné

Re: PSA Interface Checker - Verifier son interface

Message par Feel »

Bonjour à Tous,
Je suis nouveau sur ce forum et je n'arrive pas à trouver de cas similaire sur ce qui met arrivé.
J'ai fait un PC dédié à diagbox 7.57 en W7 pro 32 et prix une interface en full chip conseillé sur ce site.
Jusque-là aucun soucis je reçois mon interface et je me dis que je vais pouvoir enfin réparer mon véhicule (remplacement du BSI)
J'avais mis mon bsi vierge et j'ai donc branché pour faire la réparation de mon véhicule. Diagbox fonctionne bien mais malheureusement il faut que je branche l'ancien BSI pour telecharger les paramètres de celui-ci.
Et là le VCI ne répond plus et je le vois pas dans le gestionnaire de périphérique.
Plus de bruit quand je branche sur l'Usb et diagbox me dit VCI non connecté.
Je précise quand je le branche la led verte reste allumée mais rien et sur checker init ko.
J'ai refait plusieurs fois l'installation de windows et aussi de diagbox qui se déroule bien.
Mais rien....
Donc en gros ça a fonctionné une fois puis c'est tout.... :lol:
Si vous avez une ou des solutions je suis preneur!!!
Merci d'avance pour votre aide. :D
Et de me permettre de ressusciter ma voiture

Avatar du membre
Feel
Messages : 3
Enregistré le : mer. juil. 19, 2023 8:28 pm
Réputation : 0
Localisation : Non renseigné

Re: PSA Interface Checker - Verifier son interface

Message par Feel »

Merci Toto78 pour ton retour.
J'ai essayé de réinstaller les pilotes mais lorsque je branche l'Usb rien ne se passe et je ne vois rien dans le gestionnaire de périphérique.

Avatar du membre
Feel
Messages : 3
Enregistré le : mer. juil. 19, 2023 8:28 pm
Réputation : 0
Localisation : Non renseigné

Re: PSA Interface Checker - Verifier son interface

Message par Feel »

J'ai essayé deux câbles différents et le résultat est même et quand je branche une clé usb sur les différents ports usb sa fonctionne...je vais faire un essai en installant tout sur XP...
Merci encore pour les solutions proposées 😉

Avatar du membre
accobra02
Messages : 6
Enregistré le : mar. janv. 18, 2022 10:31 pm
Réputation : 0
Localisation : Non renseigné

Re: PSA Interface Checker - Verifier son interface

Message par accobra02 »

[Vous devez vous connecter pour voir ce contenu] a écrit : [Vous devez vous connecter pour voir ce contenu]jeu. août 10, 2023 11:01 pm Bonjour à tous, 

Merci pour le travail accomplit, 
J'utilise PP2000 et Lexia depuis de nombreuses années avec mon interface (forcément non originale) et avec un vieux pc XP. 
J'arrive aussi à utiliser Diagbox en version 5.2 avec le même PC et la même interface. 

Mon vieux PC est à bout de souffle, et je suis limité pour les véhicules plus récent (exemple une 508 de 2016 ne fonctionne pas avec mes vielles versions). Donc j'ai récupéré un pc plus moderne pour installer la machine virtuelle "Maxi VM Rev03". 

Dans l'ordre : 
- installation machine virtuelle Ok 
- lancement de la machine virtuelle, branchement de l'interface, elle est bien reconnue en usb et la led verte reste allumée
- Avec interface checker j'ai bien :
Version : APPLI XS Fuji P106138A V4.4.0 @ Actia 17.09.20
Référence : 921815 C/    Inconnue
INIT OK
- Je démarre Diagbox 
- Et j'essaie sur ma 207, il ne trouve pas le Vin automatiquement, et à la lecture diag il ne trouve aucun calculateur (absence de dialogue sur toutes les lignes)

J'ai du mal à comprendre, je sais que mon interface fonctionne avec mes vieux logiciels, et vu ce que m'annonce Interface checker, le dialogue avec Diagbox devrait fonctionner ?! 

Pouvez vous m'aider à trouver la cause du problème ? 

Merci 
Bruno 

Bonjour, 

Je complète mon message précédent car j'ai fait des nouveaux tests aujourd'hui avec le même pc.
- Machine virtuelle Maxi VM Win 7 64b et Diagbox 9.91 => absence de communication alors que interface checker dit Init OK
- Machine virtuelle Win 10 64b Diagbox 9.129 => absence de communication alors que interface checker dit Init OK
- Machine virtuelle Win XP 32b Diagbox 7.57 => absence de communication alors que interface checker dit Init OK
- Machine virtuelle Win XP 32b Diagbox 5.20 => c'est une que j'ai créé avec la version de Diagbox que j'avais reçu quand j'ai acheté l'interface (environ 15 ans)

Donc on dirait que simplement mon interface est trop vieille ... 
Est ce possible que tout soit ok avec interface checker et qu'une interface ne fonctionne pas avec des versions de Diagbox trop récente ? 

Merci 
Bruno 

Avatar du membre
accobra02
Messages : 6
Enregistré le : mar. janv. 18, 2022 10:31 pm
Réputation : 0
Localisation : Non renseigné

Re: PSA Interface Checker - Verifier son interface

Message par accobra02 »

Oui c'est ce que j'ai choisi. 
Et pour faire ma machine virtuelle avec Diagbox v5.20, j'ai simplement fait un clone de la machine V7.57 où j'ai désinstallé Diagbox et installé ma version.

Je vais tenté de télécharger la version 7.57 en native avec la méthode du clône comme pour la v5.20.

 

Avatar du membre
accobra02
Messages : 6
Enregistré le : mar. janv. 18, 2022 10:31 pm
Réputation : 0
Localisation : Non renseigné

Re: PSA Interface Checker - Verifier son interface

Message par accobra02 »

Ce n'est pas un mix, c'est juste que j'ai installé plusieurs machines virtuelles sur mon nouveau pc, car  :
- j'ai voulu essayer toutes les versions disponibles ici 
- je voulais être sur que mon interface fonctionne bien 
- j'ai besoin de faire un diag ce dimanche sur un C3 picasso, donc il me faut une version fonctionnelle.

Pour la v5.20 : 
J'ai fait une nouvelle Machine virtuelle par un clonage de la V7.57, désinstallé le V7.57 et installé ma version de v5.20 (elle a fonctionné hier soir sur 207 Sw). 
Pour le clonage j'ai choisi l'option "clone intégrale"
​​​​​​​
Les autres versions sont directement les machines virtuelles téléchargé via les liens du forum. 

 

Avatar du membre
demart9720
Messages : 2
Enregistré le : mar. sept. 05, 2023 9:09 am
Réputation : 0
Localisation : Non renseihaute garonnegné

Re: PSA Interface Checker - Verifier son interface

Message par demart9720 »

bonjour
merci pour se super boulot
 

Avatar du membre
grimmy57
Messages : 5
Enregistré le : ven. sept. 22, 2023 8:44 am
Réputation : 0
Localisation : Moselle

Re: PSA Interface Checker - Verifier son interface

Message par grimmy57 »

Bonjour,

Je rencontre aussi un problème de dialogue ou pas de communication, la led reste bleu fixe, Dialbox fait bien la mise à jour du boitier à l'ouverture du soft.

Je check la version et elle me semble correcte.

[Vous devez vous connecter pour voir ce contenu]


J'utilise Dialbox 9.85 du site sur Windows 10, est-ce que cette version est bien compatible.
Et le boiter quand il communique la led reste fixe ou doit clignoter voir est-ce qu'on doit entendre un clic d'un relai comme pour le DS150e.
Ou est-ce que mon boiter et déjà hs.

Merci
 

Avatar du membre
HarryKleins
Messages : 13
Enregistré le : jeu. sept. 07, 2023 8:27 am
Réputation : 0
Localisation : Non renseigné

Re: PSA Interface Checker - Verifier son interface

Message par HarryKleins »

Salut,

Comment forcer la mise à jour avec PSA Interface Checker ?

Merci 

Avatar du membre
bzouf57
Messages : 15
Enregistré le : sam. déc. 24, 2022 2:59 pm
Réputation : 0
Localisation : Moselle

Re: PSA Interface Checker - Verifier son interface

Message par bzouf57 »

Bonjour à tous j'ai un souci j'ai MV avec Diagbox9.129 

quand je lance PSA interface checker V3 j'ai Init KO et dans le gestionnaire de périphérique j'ai périphérique inconnu

pouvez vous m'aider car je ne sais pas d'ou ca vient merci
 

Avatar du membre
Sathard
Messages : 2
Enregistré le : lun. févr. 20, 2023 8:29 pm
Réputation : 0
Localisation : Loire Nord

Re: PSA Interface Checker - Verifier son interface

Message par Sathard »

Bonjour,

J'ai le même problème sous Win 10 Home (Activate = Init KO).
Le programme "Interface Install" ne peut pas se lancer à cause de : "unknown OS version".
La lecture de l'interface fonctionne sous VM, mais je ne peux pas rebasculer mon interface en 4.3.2 pour utiliser mon Lexia 7.57 en VM (sur Evasion de 2000).

Auriez-vous une solution soit pour faire fonctionner PSA Interface Checker en direct sous Win 10, soit pour pouvoir intégrer différentes versions du firmware dans la VM 9.129 ?

Je suis loin de maitriser l'utilisation des VM. :?

Merci d'avance !

 

Avatar du membre
Brtss
Messages : 1
Enregistré le : jeu. déc. 21, 2023 2:11 pm
Réputation : 0
Localisation : Non renseigné

Re: PSA Interface Checker - Verifier son interface

Message par Brtss »

Bonjour :)

J'ai acheté une interface non "full chip" (je ne m'en étais pas rendu compte au moment de la commande) et il semblerait qu'effectivement elle ne communique pas avec mon véhicule. Voici quelques observations :

- Véhicule : Citroën C3 II
- Logiciel : j'ai essayé avec
  • VirtualBox + Diagbox 7.83
  • VMware + Diagbox 9.129 (lien du forum)
- Quand je branche l'interface à l'ODB de mon véhicule et à mon PC, la led de l'interface clignote en bleu.
- Sur Diagbox, quand je choisis un véhicule, un message me demande de "connecter une VCI"
- Sur PSA Interface Checker, quand je fait "activation" ca me met "INIT KO" (j'ai essayé la version déjà installé avec Diagbox 9.129, ainsi que celle de cette discutions, aussi bien installé sur la VW que directement sur mon PC, toujours KO...) 

Le revendeur a accepté le retour et remboursement du produit, mais avant de le renvoyer, je voulais être sur que j'ai tout essayé. C'est pourquoi je voulais vous demander votre avis svp. Voyez vous d'autres choses à tester pour confirmer que l'interface ne communique pas avec le véhicule svp ?
Merci d'avance.
 

Avatar du membre
Rom24
Messages : 4
Enregistré le : sam. janv. 06, 2024 1:17 pm
Réputation : 0
Localisation : Dordogne

Re: PSA Interface Checker - Verifier son interface

Message par Rom24 »

Bonjour à tous,

Je viens d'acquérir un Diagbox 9.129, qui fonctionne parfaitement sur la plupart de mes voitures sauf ma 106 de 1998. Du coup je me suis installé une vielle version de PP2000 (et cette version marche sur ma 106) sur une machine virtuelle en windows XP mais il me faudrait le firmware 4.2.2 pour que je le télécharger dans ma vci, est-ce quelqu'un aurait ça ?
merci d'avance pour vos réponses ;)

Avatar du membre
sioux
Donateur ♥
Messages : 524
Enregistré le : ven. juin 04, 2021 6:31 pm
Réputation : 700
Localisation : Moselle

Re: PSA Interface Checker - Verifier son interface

Message par sioux »

[Vous devez vous connecter pour voir ce contenu] a écrit : [Vous devez vous connecter pour voir ce contenu]sam. janv. 06, 2024 2:33 pm Bonjour à tous,

Je viens d'acquérir un Diagbox 9.129, qui fonctionne parfaitement sur la plupart de mes voitures sauf ma 106 de 1998. Du coup je me suis installé une vielle version de PP2000 (et cette version marche sur ma 106) sur une machine virtuelle en windows XP mais il me faudrait le firmware 4.2.2 pour que je le télécharger dans ma vci, est-ce quelqu'un aurait ça ?
merci d'avance pour vos réponses ;)

Bonjour
lien .
[Vous devez vous connecter pour voir ce contenu]
On a le droit d'avoir une opinion, mais il ne faut pas l'imposer aux autres !

Avatar du membre
Rom24
Messages : 4
Enregistré le : sam. janv. 06, 2024 1:17 pm
Réputation : 0
Localisation : Dordogne

Re: PSA Interface Checker - Verifier son interface

Message par Rom24 »

[Vous devez vous connecter pour voir ce contenu] a écrit : [Vous devez vous connecter pour voir ce contenu]sam. janv. 06, 2024 3:13 pm
[Vous devez vous connecter pour voir ce contenu] a écrit : [Vous devez vous connecter pour voir ce contenu]sam. janv. 06, 2024 2:33 pm Bonjour à tous,

Je viens d'acquérir un Diagbox 9.129, qui fonctionne parfaitement sur la plupart de mes voitures sauf ma 106 de 1998. Du coup je me suis installé une vielle version de PP2000 (et cette version marche sur ma 106) sur une machine virtuelle en windows XP mais il me faudrait le firmware 4.2.2 pour que je le télécharger dans ma vci, est-ce quelqu'un aurait ça ?
merci d'avance pour vos réponses ;)

Bonjour
lien .
[Vous devez vous connecter pour voir ce contenu]

Merci ça fonctionne impec 👍
J'ai plu qu'à trouver une clé d'activation pour le pp2000, j'ai bien un générateur de clé dans le cd d'installation mais aucune clé ne fonctionne. Si quelqu'un a une idée,
merci d'avance 😉

Avatar du membre
Rom24
Messages : 4
Enregistré le : sam. janv. 06, 2024 1:17 pm
Réputation : 0
Localisation : Dordogne

Re: PSA Interface Checker - Verifier son interface

Message par Rom24 »

Ça y est j'ai réussi à activer mon PP2000, petite erreur de ma part lors de la saisie des données dans le générateur de clé 😁.
Mon PP2000 démarre correctement mais un message d'erreur apparait lorsque je me connecte à ma voiture.
"Erreur d'application
WINCAD a caus, une faute de protection général dans le module WIN87EM.DLL ... L'adresse 0001:02C9.
Choisissez le bouton fermer, WINCAD va se fermer "
Encore merci pour votre aide 😉

Avatar du membre
accobra02
Messages : 6
Enregistré le : mar. janv. 18, 2022 10:31 pm
Réputation : 0
Localisation : Non renseigné

Re: PSA Interface Checker - Verifier son interface

Message par accobra02 »

Salut, 

J'ai également eu l'erreur Wincad courant décembre sur mon mes Windows virtuelles. 
De mémoire j'ai réussi à résoudre cette erreur en applicant la méthode ci après : 
Traduction de la méthodo:
1. Télécharger "[Vous devez vous connecter pour voir ce contenu]" sur votre machine (normal ou virtualisée).
2. Crée un répertoire où vous le souhaitez sur la machine de destination (vm si virtualisé), y placer le fichier téléchargé, exécutez le, des fichiers vont être dépackagés
3. Copiez seulement le fichier extrait “HIDE87.com” dans le répertoire c:\windows\system32
4. Ouvrir le fichier “autoexec.nt” (c:\windows\system32\autoexec.nt) avec un éditeur de texte (notepad fonctionne).
5. Ajouter la ligne (sans les guillemets) “lh c:\windows\system32\HIDE87.com” dans le fichier “autoexec.nt” (à la fin ça fonctionne)
6. Enregistrer le fichier, puis sortir
7. Redémarrer la machine.
8. FaitTraduction de la méthodo:
J'ai trouvé ça sur le site suivant : 
[Vous devez vous connecter pour voir ce contenu]

Avatar du membre
Rom24
Messages : 4
Enregistré le : sam. janv. 06, 2024 1:17 pm
Réputation : 0
Localisation : Dordogne

Re: PSA Interface Checker - Verifier son interface

Message par Rom24 »

[Vous devez vous connecter pour voir ce contenu] a écrit : [Vous devez vous connecter pour voir ce contenu]lun. janv. 08, 2024 9:51 pm Salut,

J'ai également eu l'erreur Wincad courant décembre sur mon mes Windows virtuelles.
De mémoire j'ai réussi à résoudre cette erreur en applicant la méthode ci après :
Traduction de la méthodo:
1. Télécharger "[Vous devez vous connecter pour voir ce contenu]" sur votre machine (normal ou virtualisée).
2. Crée un répertoire où vous le souhaitez sur la machine de destination (vm si virtualisé), y placer le fichier téléchargé, exécutez le, des fichiers vont être dépackagés
3. Copiez seulement le fichier extrait “HIDE87.com” dans le répertoire c:\windows\system32
4. Ouvrir le fichier “autoexec.nt” (c:\windows\system32\autoexec.nt) avec un éditeur de texte (notepad fonctionne).
5. Ajouter la ligne (sans les guillemets) “lh c:\windows\system32\HIDE87.com” dans le fichier “autoexec.nt” (à la fin ça fonctionne)
6. Enregistrer le fichier, puis sortir
7. Redémarrer la machine.
8. FaitTraduction de la méthodo:
J'ai trouvé ça sur le site suivant :
[Vous devez vous connecter pour voir ce contenu]

C'est bon, j'ai fait les modifications et ça marche, encore merci 😉.
Seul problème maintenant ma Vci refuse toujours de communiquer avec ma 106, alors que ça marche avec une autre Vci qu'on m'a prêté, la seule différence entre les deux c'est le numéro de série 921815C pour la mienne et 963830B pour l'autre.

Avatar du membre
pascaldal
Messages : 8
Enregistré le : dim. févr. 04, 2024 10:37 pm
Réputation : 1
Localisation : 80

Re: PSA Interface Checker - Verifier son interface

Message par pascaldal »

Bonjour à tous,

Je possède une interface Actia 9780.Z5 "PSA XS EVOLUTION" numéro de série 921815B que j'ai achetée il y a environ 5 ans sur Internet (elle était donnée pour être "full chips").
Je l'avais flashé en 921815C avec une rom que NLC m'avait envoyée pour que cette interface soit bien détectée en "USB COM Board Evolution Driver ( UMDF )" (ou "USB COM Board Evolution Driver ( multi instance )" selon l'OS) ce qui permet d'éviter des problèmes de déconnexion sur DiagBox. Cette interface fonctionnait très bien sur DiagBox 7.57 que j'utilisais avec ma DS5 de 2015 si ce n'est que quelques calculateurs n'étaient pas bien reconnus (le DiagBox étant un peu ancien pour la voiture).

J'ai acheté une DS7 (de 2018) et donc je suis passé à DiagBox 9.91 afin que celui-ci reconnaisse mon véhicule (et les calculateurs associés), j'ai donc flashé mon interface avec le firmware correspondant (4.4.0) et celui-ci est bien reconnu par DiagBox sauf qu'au moment d'identifier le VIN du véhicule cela ne fonctionne pas. Si je le rentre à la main je constate que l'interface ne parvient à communiquer qu'avec un seul calculateur "TMC" (ou ce genre de chose, en lien avec la gestion de la tension) sur les à peu près 50 que compte le véhicule. Autant dire que cela perd tout son intérêt.

Je pensais qu'il s'agissait d'une incompatibilité de mon interface avec DiagBox 9.91, sauf que j'ai tenté de me connecter sur la DS5 avec et là tout fonctionne parfaitement (et cette fois-ci tous les calculateurs sont correctement reconnus par la version plus récente de DiagBox).

Cela signifie donc que mon interface 921815B, flashée en 921815C fonctionne très bien sur la DS5 de 2015 mais pas sur la DS7 de 2018. Comment est-ce possible ? Faut-il changer l'interface ?

Merci de me lire et mieux encore : de répondre ;-)

Avatar du membre
pascaldal
Messages : 8
Enregistré le : dim. févr. 04, 2024 10:37 pm
Réputation : 1
Localisation : 80

Re: PSA Interface Checker - Verifier son interface

Message par pascaldal »

Bonjour Toto, effectivement je n’ai pas pris le temps de me présenter j’en suis désolé. Je viens de le faire, à bientôt :-)

Avatar du membre
sioux
Donateur ♥
Messages : 524
Enregistré le : ven. juin 04, 2021 6:31 pm
Réputation : 700
Localisation : Moselle

Re: PSA Interface Checker - Verifier son interface

Message par sioux »

[Vous devez vous connecter pour voir ce contenu] a écrit : [Vous devez vous connecter pour voir ce contenu]ven. févr. 23, 2024 4:33 pm Bonjour à tous,

Je possède une interface Actia 9780.Z5 "PSA XS EVOLUTION" numéro de série 921815B que j'ai achetée il y a environ 5 ans sur Internet (elle était donnée pour être "full chips").
Je l'avais flashé en 921815C avec une rom que NLC m'avait envoyée pour que cette interface soit bien détectée en "USB COM Board Evolution Driver ( UMDF )" (ou "USB COM Board Evolution Driver ( multi instance )" selon l'OS) ce qui permet d'éviter des problèmes de déconnexion sur DiagBox. Cette interface fonctionnait très bien sur DiagBox 7.57 que j'utilisais avec ma DS5 de 2015 si ce n'est que quelques calculateurs n'étaient pas bien reconnus (le DiagBox étant un peu ancien pour la voiture).

J'ai acheté une DS7 (de 2018) et donc je suis passé à DiagBox 9.91 afin que celui-ci reconnaisse mon véhicule (et les calculateurs associés), j'ai donc flashé mon interface avec le firmware correspondant (4.4.0) et celui-ci est bien reconnu par DiagBox sauf qu'au moment d'identifier le VIN du véhicule cela ne fonctionne pas. Si je le rentre à la main je constate que l'interface ne parvient à communiquer qu'avec un seul calculateur "TMC" (ou ce genre de chose, en lien avec la gestion de la tension) sur les à peu près 50 que compte le véhicule. Autant dire que cela perd tout son intérêt.

Je pensais qu'il s'agissait d'une incompatibilité de mon interface avec DiagBox 9.91, sauf que j'ai tenté de me connecter sur la DS5 avec et là tout fonctionne parfaitement (et cette fois-ci tous les calculateurs sont correctement reconnus par la version plus récente de DiagBox).

Cela signifie donc que mon interface 921815B, flashée en 921815C fonctionne très bien sur la DS5 de 2015 mais pas sur la DS7 de 2018. Comment est-ce possible ? Faut-il changer l'interface ?

Merci de me lire et mieux encore : de répondre ;-)

Bonjour
Essayez une autre version de Diagbox avant d’incriminer l'interface, sachez qu'en fonction des marques et modèles de Calculateurs, on rencontre souvent des difficultés à dialoguer avec eux surtout avec diagbox non officiel. Il y a trop de variables qui peuvent causer ce dysfonctionnement.
On a le droit d'avoir une opinion, mais il ne faut pas l'imposer aux autres !

Avatar du membre
pascaldal
Messages : 8
Enregistré le : dim. févr. 04, 2024 10:37 pm
Réputation : 1
Localisation : 80

Re: PSA Interface Checker - Verifier son interface

Message par pascaldal »

J’ai oublié de préciser dans mon précédent message Mais j’ai fait le test avec 3 versions de diagbox différentes : 7.57, 7.88 et 9.91 et le résultat est le même. Aucun dialogue avec la ds7 sauf sur un calculo, aucun problème avec la ds5 (tous les calculos répondent).

Il semble donc que la ds7 ne communique pas de la même manière que la ds5, ce qui m’étonne c’est que la ds5 doit partager un certain nombre de calculateurs avec la ds7 (mais je peux me tromper) aussi ce résultat est très surprenant pour moi et ne semble clairement documenté nulle part. J’ai juste pu lire à droite et à gauche que les interfaces avec la référence 921815C sont nécessaires pour les véhicules récents mais sans expliquer sur quelle base cela se repose. En effet mon interface étant censée être une full chips, mais avec la réf 921815B, quelles sont concrètement les différences entre les deux et qu’est ce qui expliquent qu’une voiture de 2015 fonctionne très bien mais pas une de 2018 ?
Modifié en dernier par pascaldal le dim. févr. 25, 2024 6:03 pm, modifié 1 fois.

Avatar du membre
sioux
Donateur ♥
Messages : 524
Enregistré le : ven. juin 04, 2021 6:31 pm
Réputation : 700
Localisation : Moselle

Re: PSA Interface Checker - Verifier son interface

Message par sioux »

[Vous devez vous connecter pour voir ce contenu] a écrit : [Vous devez vous connecter pour voir ce contenu]dim. févr. 25, 2024 2:35 pm J’ai oublié de préciser dans mon précédent message Mais j’ai fait le test avec 3 versions de diagbox différentes : 7.57, 7.88 et 9.91 et le résultat est le même. Aucun dialogue avec la ds7 sauf sur un calculo, aucun problème avec la ds5 (tous les calculos répondent).

Il semble donc que la ds7 ne communique pas de la même manière que la ds5, ce qui m’étonne c’est que la ds5 doit partager un certain nombre de calculateurs avec la ds7 (mais je peux me tromper) aussi ce résultat est très surprenant pour moi et ne semble clairement documenté nulle part. J’ai juste pu lire à droite et à gauche que les interfaces avec la référence 921815C sont nécessaires pour les véhicules récents mais sans expliquer sur quelle base cela se repose. En effet mon interface étant censée être une full chips, mais avec la réf 921815B, quelles sont concrètement les différences entre les deux et qu’est ce qui expliquent qu’une voiture de 2015 fonctionne très bien mais pas une de 2018 ?

Si Diagbox ne reconnait pas le vin d'un véhicule automatiquement il y a une forte probabilité qu'il ne dialoguera pas avec tous les calculateurs, anciens ou récents véhicules c'est exactement la même chose. La reconnaissance automatique du vin est à mon avis une condition logique "ET" + X pour dialoguer avec les calculateurs dans son algorithme.
On a le droit d'avoir une opinion, mais il ne faut pas l'imposer aux autres !

Avatar du membre
pascaldal
Messages : 8
Enregistré le : dim. févr. 04, 2024 10:37 pm
Réputation : 1
Localisation : 80

Re: PSA Interface Checker - Verifier son interface

Message par pascaldal »

Sioux,

Oui effectivement il est très probable que cela soit lié mais pour autant je n’ai pas d’explication sur ce phénomène pour l’instant et je n’en ai pas trouvé

Avatar du membre
Nono67
Messages : 1
Enregistré le : lun. sept. 11, 2023 8:30 pm
Réputation : 0
Localisation : 67

Re: PSA Interface Checker - Verifier son interface

Message par Nono67 »

Bonjour,
j'ai une interface qui doit avoir une dizaine d'année.
Lorsque je fais le test avec Interface Checker je n'obtiens pas de numéro de série.
La version application qui m'est retournée est APPLI_XS_Fuji_ P106138A V4.4.0 @ACTIA 17.09.20

A droite du bouton Reference il y a écrit Inconnue

Sur le boitier j'ai une étiquette avec un numéro commençant par 921815B/ Est-ce le numéro de série?

Je peux me connecté au véhicule avec l'interface (une 206+) en choisissant 206 mux, j'ai accès aux différents calculateurs sauf le calculateur moteur.
Faut-il que je me procure une autre interface pour accéder au caculateur moteur?
 

Avatar du membre
sioux
Donateur ♥
Messages : 524
Enregistré le : ven. juin 04, 2021 6:31 pm
Réputation : 700
Localisation : Moselle

Re: PSA Interface Checker - Verifier son interface

Message par sioux »

Bonjour

En fait si Diagbox ne reconnait pas automatiquement le VIN il y a de grande chance que le dialogue avec le calculateur moteur ne se fasse pas .
On a le droit d'avoir une opinion, mais il ne faut pas l'imposer aux autres !

Avatar du membre
pascaldal
Messages : 8
Enregistré le : dim. févr. 04, 2024 10:37 pm
Réputation : 1
Localisation : 80

Re: PSA Interface Checker - Verifier son interface

Message par pascaldal »

[Vous devez vous connecter pour voir ce contenu] a écrit : [Vous devez vous connecter pour voir ce contenu]dim. févr. 25, 2024 6:06 pm Sioux,

Oui effectivement il est très probable que cela soit lié mais pour autant je n’ai pas d’explication sur ce phénomène pour l’instant et je n’en ai pas trouvé

J'ai finalement acheté une nouvelle interface, en me disant que peut-être pour communiquer avec les véhicules récents (>= 2017) il fallait une puce ou quelque chose en plus (sans trop y croire franchement, mais j'ai tenté). Evidemment cela ne change rien.

J'ai donc fait autrement : j'ai téléchargé la version officielle de Diagbox (et ouai je n'aime pas ne pas comprendre et là je ne comprends pas pourquoi ça ne marche pas, pour moi cela devrait fonctionner) via achat d'un jeton, tout ça.
Je vous le donne en mille : ça ne fonctionne pas mieux, que ce soit avec mon ancienne interface ou la nouvelle, à noter d'ailleurs que les deux sont bien reconnues par le soft mais mon ancienne est systématiquement flashée alors qu'elle est déjà en v.4.5.0, bizarre...

Aussi j'en viens à penser à un problème au niveau du connecteur OBD2 de ma voiture (je veux comprendre), et comme j'arrive à communiquer via l'ardhuino en utilisant une nappe que je pensais être une nappe de rallonge j'ai testé la continuité de chaque pin pour me rendre compte qu'il s'agit en fait d'une nappe qui intervertir certains fils !!!

Autrement dit ça fait des heures que je teste sans cette nappe (car j'y avais fait un montage "bricolé" pour l'arduino que je ne voulais pas défaire) pour me rendre compte que celle-ci est indispensable pour que cela fonctionne. J'ai donc testé avec cette nappe, et là : toujours rien ! que ce soit avec l'ancienne interface ou la nouvelle. 

Je vous avoue que je commence à désespérer mais je suis quelqu'un de tête et je vais continuer de chercher. Mon arduino d'utilise que 3 fils, je pense que le diagbox en utilise plus. Il est encore possible qu'il y ait un problème de connectivité/conductivité quelque part, je dois encore faire des tests prochainement. En tout cas je n'ai JAMAIS vu cette info ailleurs sur le net, le connecteur OBD2 des voitures récentes n'est pas câblé en respectant le brochage habituel, cela pour se prémunir du démarrage/vol depuis le connecteur OBD2 je pense. Il fallait le savoir, reste que ce n'est visiblement pas la cause de mon problème (et là franchement j'y croyais).  

Avatar du membre
0x7b4
Messages : 18
Enregistré le : sam. mars 26, 2022 9:51 am
Réputation : 36
Localisation : Finistère
Contact :

Re: PSA Interface Checker - Verifier son interface

Message par 0x7b4 »

Bonjour [Vous devez vous connecter pour voir ce contenu],

Le connecteur db15 vers usb utilise 4 fils :

1 gnd
2 ?
3 ?
4 ?
5 ?
6 gnd
7 usb d+
8 +5V
9 usd d-
10 ?
11 gnd
12 ?
13 ?
14 ?
15 gnd

Les autres c'est peut être des signaux..

Avatar du membre
pascaldal
Messages : 8
Enregistré le : dim. févr. 04, 2024 10:37 pm
Réputation : 1
Localisation : 80

Re: PSA Interface Checker - Verifier son interface

Message par pascaldal »

Merci 0x7b4, en fait on peut facilement retrouver les signaux de chaque broche du connecteur obd2, ainsi que celles utilisées par PSA (leur canh et canl utilisent 2 broches dédiés aux constructeurs) mais lorsque je regarde les fils derrière mon connecteur obd2 de la ds7 cela ne colle pas. Et pour cause il faut que j’utilise une nappe spécifique à ma voiture que je branche sur mon connecteur de voiture afin d’obtenir un connecteur obd2 normalement câblé. Je pense que c’est une mesure anti vol permettant d’empêcher des voleurs d’utiliser ce connecteur…

Et enfin la bonne nouvelle : la nouvelle interface fonctionne. Au début j’avais un fonctionnement assez chaotique / complètement aléatoire, j’ai dû insister pour avoir un premier résultat et c’est un peu par hasard que je me suis rendu compte que l’interface avait réussi à communiquer avec quelques calculateurs (5 ou 6, sur les environs 60 de mon véhicule). Parfois le VIN est détecté, d’autres fois non, et cela ne présage pas forcément de la communication avec les calculateurs. J’ai remarqué cependant que ça fonctionne bien mieux en installant diagbox en natif, la communication avec la VCI sur machine virtuelle est franchement beaucoup trop aléatoire dans mon cas. En plus je me suis rendu compte que si mon ordinateur est branché sur le secteur alors cela impacte négativement la communication aussi, probablement car je passe par une rallonge sur la quelle j’ai aussi raccordé un chargeur de batterie de voiture qui semble envoyer beaucoup de parasite sur mon PC (mon touchpad fonctionne de manière chaotique dès que je suis branché, je suis sûr que cela parasite aussi les ports usb et la communication avec la VCI).

Bref vous l’aurez compris il vaut mieux éviter d’utiliser une machine virtuelle (une installation native fonctionne bien mieux) et ne pas faire comme moi et brancher un chargeur de batterie de voiture sur la même multiprises que le PC sur lequel tourne DiagBox…

Pour info j’ai un compte service box et j’ai acheté un jeton afin d’installer et d’utiliser la version officielle. L’avantage c’est que cela me permet de télécoder, en revanche sur mon véhicule (ds7) tous les telecodages sont automatiques, pour passer en manuel il faut un contre code d’autorisation. À mon avis avec mon compte « indépendant » je ne peux pas y avoir accès car il faut avoir suivi des formations spécifiques.

Je suis censé également pouvoir faire des téléchargement pour mettre à jour les logiciels des calcules mais à chaque fois diagbox me dit que la batterie de servitude a une tension trop faible pour ça (alors que je suis branché à un chargeur de batterie : il m’indique 12,5v, ce qui n’est pas suffisant à priori. Ce qui m’étonne tout de même et si quelqu’un a une idée pour résoudre le problème je suis preneur ;-))

J’ai également refait des tests avec mon ancienne interface mais ça ne fonctionne toujours pas (plus précisément sur quelques calculateurs le rapport indique que l’interface peut télécharger mais pas diagnostiquer. J’avoue ne pas avoir essayé sur diagbox natif, en débranchant du PC donc il fauterait que je prenne le temps de faire un dernier essai dans ces conditions avant de conclure sur mon interface à un soucis.

L’ancienne interface est une « full chips», ce n’est pas du tout le cas de la nouvelle qui semble être un modèle simplifié aussi bien en terme d électronique que de câbles (il n’y a plus le clip ni les pinces). De plus l’interface n’est plus détectée du tout comme un device « actif multi instances » mais juste comme un « port série », il est donc inutile d’utiliser psaInterfaceChecker avec car non compatible. J’ai galéré à la faire reconnaître par diagbox mais il semble qu’il faille en définitif juste copier une dll dans un dossier de diagbox et lancer un fichier reg pour enregistrer le driver…


Voilà pour les nouvelles, si cela peut en aider certains tant mieux !
Modifié en dernier par pascaldal le ven. avr. 19, 2024 5:56 pm, modifié 3 fois.

Avatar du membre
georgio39230
Messages : 48
Enregistré le : dim. févr. 25, 2024 2:33 pm
Réputation : 12
Localisation : JURA

Re: PSA Interface Checker - Verifier son interface

Message par georgio39230 »

Salut et merci de ton retour!

Répondre